My Home Cisco Router/Switch Setup

So some number of years ago, I purchased a Cisco series router and catalyst switch but I only messed around on them to learn and never really used them in “production”. So below are my configs and some pictures of my home network setup.

# cisco catalyst 3500

enable
configure terminal

# restore factory defaults

write erase
reload
show running-config
show version

# 802.1q vlan trunk

interface fastEthernet 0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit

# 802.1q vlan access

int fastEthernet 0/2
switchport access vlan 2
exit

# disable some stuff

no ip http server
no ip http secure-server
exit

# save the config

write memory

# cisco series 2600

enable
configure terminal

# restore factory defaults

write erase
reload
show running-config
show version

# 802.1q inter vlan routing

int fastEthernet 0/1
no shut
exit

int fastEthernet 0/1.1
encapsulation dot1Q 1 native
exit

int fastEthernet 0/1.2
encapsulation dot1Q 2
ip address 192.168.10.1 255.255.255.0
ip nat inside
exit

# enable dhcp client

int fastEthernet 0/0
no shut
ip address dhcp
ip nat outside
exit

# nat

int fastEthernet 0/0
ip access-list standard NAT
permit 192.168.10.0 0.0.0.255
ip nat inside source list NAT interface fastEthernet 0/0 overload
exit

# disable some random stuff

no ip http server
no ip http secure-server
exit

# save the config

write memory

# openwrt configurations

ssh 192.168.1.1

# wpa2-ccmp-eap-ttls

opkg update
opkg install `opkg list | grep -i 'freeradius' | awk '{ print $1 }'`
opkg install `opkg list | grep -i 'hostap' | awk '{ print $1 }'`
opkg install `opkg list | grep -i '802.1x' | awk '{ print $1 }'`
opkg remove wpad-mini
opkg install hostapd wpa-supplicant

# startup

uci set wireless.@wifi-iface[0].encryption="wpa2+ccmp"
uci set wireless.@wifi-iface[0].key="Drowssap1!"
uci set wireless.@wifi-iface[0].server="1.2.3.4"
uci set wireless.@wifi-iface[0].port="1812"
uci commit wireless
/sbin/wifi

# netgear wndr3700v2 vlans – port numbers are ordered in reverse above

# tplink wdr4300 vlans

# interface vlan addresses – assign them to the lan fw group

Advertisements
My Home Cisco Router/Switch Setup

One thought on “My Home Cisco Router/Switch Setup

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s